Software hall of fame

Resources

Windows

Linux

Platform-independent

Tip & Tricks

[Windows]

In case you need to move files in "My Documents" from one user account to another:

  1. Log in as Admin
  2. Move the files and folders to the non-admin's directory
  3. Select each folder that contains files we moved in step 2, right click and select Properties.
  4. Go to the Security tab.
  5. Click the Edit button
  6. If the non-admin's username is not listed in the list of User Names, click Add and add their name.
  7. Select the name in the list of User Names, then click Allow for Full Control (if they cannot select Full Control, add their name (step 6) even if it is already listed).
  8. Press OK to return to the Properties dialog and then press Advanced.
  9. In the Permissions tab click Change Permissions.
  10. Make sure their name has the Full Control permission and then check "Replace all child object permissions..." and press OK to apply these permissions to all the files and folders.
  11. Click the Owner tab. In the "Change owner to" window select their username (if their name is not listed, click Edit and add their name using the "Other users or groups" button).
  12. Press OK and choose to apply the changes to all files and folders and subfolders etc...

This way they have their own account as having Full Control permissions (so they can do anything with the files) and Ownership (so they are allowed to change permissions themselves).

Logging in as the non-admin's own account, and you should be able to access and control the files as one's own again.

Mongoose

Here's a basic configuration file (save as mongoose.conf alongside the binary):

listening_ports 12345

AoA Audio Extractor

Useful to extract audio from an MP4 video.

[Fiddler] Fiddler

To find and remove sessions, ie. items in the left hand-side that fit a pattern, Edit > Find Sessions, and DELETE. To delete all sessions, CTRL+X.

[Fiddler] Nothing displayed

If nothing is displayed while you browse web pages, select Help > Troubleshoot Filters to see if some requests could be hidden due to some faulty setting.

[OpenOffice 3.2/Calc] Moving cell

It's a bit awkward:

  1. Click once to put the focus on the cell
  2. SHIFT-click to select the cell
  3. Drag and drop it

[OpenOffice 3.2/Calc] Updatable absolute references

Let's say you have a value in B5 that you'd like to use in different cells by just copy/pasting a formula so that this reference would not be updated when pasted in a new cell: You must use the $ for both the horizontal and vertical references, eg. =$B$5*0,065

[OpenOffice 3.2/Calc] Moving a row

Select the row, keep the ALT pressed, click on the row, drag 'n drop it below the row where you want it, and release the mouse.

Move, copy, and link cells using drag and drop

[OpenOffice 3.1.1/Calc] Moving a column

  1. Click on the header to select the whole column
  2. Drag the first cell, which is now shown with a black bold line
  3. While dragging, hold the ALT key, and drop the column wherever your want

Not very intuitive, and not as simple as drag 'n drop in Excel :-/

[OpenOffice 3.1.1/Writer] Working with bullets

To change the space between the bullet and the first letter in the block: Format>Bullets and Numbering...>Position

To add some space after a bulleted block: Format>Paragraph Spacing Below paragraph

[Windows] Disabling CAPSLOCK

Download and double-click on this file to add information to the Registry

http://johnhaller.com/jh/useful_stuff/disable_caps_lock/

[Windows] Searching for filenames with digits as extensions

I wanted to look through my hard-disk to find temporary files left by UltraEdit after I killed it. The filenames look like Edit.123, ie. "Edit" and a three-digit extension.

Here's how to do it from a DOS prompt:

dir /b /s c:\ | findstr /r "Edit\.[0-9][0-9][0-9]$"

You can also use GrepWin or the GNU port of grep. Or TotalCommander.

[XP] Connecting with Remote Desktop without a password

Control Panel > Administrative Tools > Local Security Policy > Security options > Accounts: Limit local account use of blank passwords to console logon only : Set that to disable, and you will be able to remote desktop without the need for a password

Removing copy protection from a PDF file

  1. Install GhostScript and its GUI GhostView
  2. Open the PDF file in GhostView
  3. File > Convert, and saved as eg. DUMMY.PDF

The contents of DUMMY.PDF can now be copy/pasted :-) Alternatively, use xpdf and a patch

Uploading files through FTP with ncftpput

http://www.ncftp.com/ncftp/doc/faq.html

http://www.ncftp.com/ncftp/doc/ncftpput.html

"C:\Program Files\NcFTP\ncftpput.exe" -R -u mylogin -p mypass ftp.acme.com /source/c *.c

Uploading files through FTP with cURL

http://curl.haxx.se/docs/manpage.html

http://curl.haxx.se/docs/faq.html

http://curl.haxx.se/docs/manual.html

Uploading files through FTP with wput

for %%f in (c:\sourc\*.c) do wput -vN %%f ftp://mylog:mypass@ftp.acme.com/source/c/

Errors:

ImageMagick

Here's how to resize a bunch of pictures under Windows using ImageMagick:

for %%f in (*.jpg *.jpeg *.gif *.png) do "C:\Program Files\ImageMagick-6.3.0-Q16\imconvert.exe %%f -resize 50%% +profile "*" test\%%f"

"The system cannot find the path specified."?

Opera 9.w

To disable the dragging of objects (eg. pictures, links), something I find very annoying, edit opera6.ini in your profile, go to section [User Prefs], and set Enable Drag=0. 

http://www.opera.com/support/usingopera/operaini/

That done, here are things to change through the Tools menu if you want 9.x to behave like previous versions of Opera:

Appearance

Preferences

Note: Here are the settings in Opera 8.54:

Total Commander

Comparing two directories

To compare two directories including their sub-directories (useful to only upload files that changed to an FTP server): Commands > Synchronize Dirs

Accented characters not displayed in UTF8 documents

When using the internal file lister (ie. hitting F3) to view an UTF8-encoded file that contains accented characters, some characters aren't displayed. The reason is that the default System Fixed Font in Windows is missing these characters. Try to use a different fixed font, e.g. Courier New.

Change shell

To tell TC to use a different shell from the default cmd.exe, change the system environment variable COMSPEC.

%SystemRoot%\system32\cmd.exe

UltraEdit

Including CRLF in the . character

By default, "." doesn't include CRLF characters. As explained here,  prepend the search pattern with "(?s)" to tell the (Perl, ie. Boost) regular expression library to change this behavior.

Adding file versioning

As of 15.10 at least, UE doesn't provide file versioning. A work-around is to use a light Source Control Manager (SCM), and call it from UE.

  1. Download and install the single-binary Fossil SCM, and update your PATH so Windows can find it
  2. Create the following DOS batch file, eg. c:\fossil.ue.add.commit.bat:

    @echo off
    fossil.exe add %1
    fossil.exe commit -m "some comment"
     
  3. Add a menu in UE to add/commit files: Advanced > Tool Configuration:

    Commande Line = C:\fossil.ue.bat "%f"
    Working Directory = %P

  4. Create a second batch file to let the user discard changes made to the file and retrieve the last revision from the repository, eg. C:\fossil.ue.revert.bat:

    @echo off
    set FileName=%~pnx1
    set FileName=%FileName:~1%
    set FileName=%FileName:\=/%
    c:\fossil.exe revert "%FileName%"
    echo "%FileName%"
    set FileName=
     
  5. Add a menu through Advanced > Tool Configuration:

    Command Line = C:\fossil.ue.revert.bat "%f"
    Working Directory = %P

"Can't create temporary file"

If you see this error message when creating a new page, it could be that there are too many files in the temporary directories: Start > Accessories > System Tools > Disk Cleanup. Additionally, reboot, launch the minimum number of applications, and delete all directories and files in directory %temp% and C:\Windows\Temp except those which you can't delete at the moment because in use by an application.

Regex

  1. Advanced Configuration | Find : Unix Style Regular Expressions
  2. In the Search/Replace dialog : check Regular Expressions
  3. Find ^(.+)$ and replace with <td>\1</td>

Some notes about the regex function in UE:

Here's an example, where I was cleaning up an RTF file that was the exported version of an HLP file. The original part in the RTF was eg.

{\b\cf12 Edit Menu   \{button Top,JI("","INTRODUCTION")\}
\par }

... and here's the regex to find:

{\\b[^{]+{button Top,JI\("","[^"]+"\)\\}\r\n\\par }

(Free) Agent

Since I can never figure out how to set settings in the Group | Default Properties:

Mark read

What to purge

When to purge

Here's how to enable reading Japanese (Agent 1.93 at least doesn't seem to support typing Japanese, even with the IME installed):

  1. (W2K/XP) Through Control Panel, install the IME, ie. support for Japanese
  2. From the \All_COD sub-directory, copy the Japanese code page cp932.cod into Agent's main directory above, and start Agent
  3. Options > General Preferences > Languages, and click on Add...
  4. Give this new language a name, eg. "Japanese", Based on = Japanese, and hit OK. Leave the default as is, and hit OK
  5. Options > Display Preferences > Fonts : In "Fonts for the Language", select "Japanese". Next, click on "Variable-Pitch Body" and "Fixed-Pitch Body", and make sure each Script is set to "Japanese" instead of "Western", or you won't see any Japanese... Hit OK
  6. In the left pane, select the Japaneses newsgroup, eg. sci.lang.japan
  7. Group > Properties > Language = Japanese
  8. You should now be able to read Japanese posted in Nihon- or Nihongo-related newsgroups

Eudora

Here's how to get rid of the X-Sender header. More infos about this header in "What is 'X-Sender' in the message header?".

If, all of sudden, Eudora can no longer connect out to a remote POP server through a SPAM server running on localhost, and poops out "Could not connect to "127.0.0.1" Cause: connection refused (10061)", it might be that the eudora.ini file is corrupt. Close Eudora, delete this file, restart Eudora and reconfigure, ie. set it to connect to 9999, and recreate Personas.

Windows Eudora Logging Instructions

HTML Tidy

Here's how to clean a Word document saved from DOC to HTML:

tidy -m -i -u --word-2000 y myfile.html

-m  update original file

-i    indent element content

-u    force tags to upper case

Firefox

Favorite extensions:

Word 97

Here's how to print the same label on label sheets made for laser printers:

  1. Create a new document, type the text and format it as you wish (fonts, etc.)
  2. Select the text, and hit Tools > Envelopes & Labels
  3. Click on the Labels tab
  4. If the type of the label sheets isn't listed, create a new type of label by clicking on New Label
  5. Word doesn't always follow the settings that you put when creating a new label. If the margins aren't right, change them in the E&L section (Those in File > Page Setup are ignored)

Here's how to fetch data from a tab-delimited file and print labels. It's a good idea for the first row to be the header for each column (eg. Company, Address, etc.):

  1. Create a new, blank document
  2. Tools > Mail Merge: Create > Mailing Labels > Active Window
  3. Get Data > Open Data Source, point to the .TSV file
  4. Select a label type: Since Word isn't reliable, you might need to print a few test sheets before Word prints out the labels just like you need. Do this on regular sheets of paper instead of label sheets
  5. Insert Merge Field: Select the fields
  6. Merge > Merge

SmartDraw 7

Here's how to change the fill color of an arrow from the default black to another color:

  1. Select (left-click) the arrow
  2. Right-click on the arrow
  3. Select "Ungroup Objects"
  4. Click OK on the "Separate Drawing" window
  5. Select the arrow again
  6. Now the Fill and Line will apply only to the arrow, not to the whole symbol (even though it had only 1 part, the arrow)

Paint.Net

Here's how to bend an arrow-line into a curve:

 

Brename

Here's how to rename all the JPG files in the current directory using a specific prefix, and starting the numbering at the given number:

brename *.jpg store_cleveland_0 14

This will rename the files as store_cleveland_014, store_cleveland_015, etc.

PaintShopPro X

Imager, layer, new selection, transparent selection, selection, new vector selection

Raster layer, vector layer, art media layer, layer group

Recommended books?

PSP9 User's Guide

Paint Shop Pro 9 For Dummies by David C. Kay and William Steinmetz

Corel Paint Shop Pro X Revealed by Sonja Shea

Copy cropped area into clipboard

In the toolbar, select the Crop Tool, select the area you wish to keep, and click on the green check icon in the toolbar to Apply this selection.

How to set default properties of preset shapes?

By default, in PSP X at least, shapes will always use black as fill/stroke color. Actually, PSP uses the foreground color as stroke (ie. outline) and the background color as fill. So if you just want a one-color shape...

  1. Disable the foreground color
  2. Choose a color for the background (ie. fill)
  3. Choose a Preset shape
  4. Uncheck its "Retain style" option, and
  5. Draw the new shape.

PaintShopPro5

Here's how to remove part of a picture by drawing a torn effect:

  1. Select the Freehand tool (looks like a lasso)
  2. To select the area you want to keep, keep the mouse button, draw an even line from left to right so it looks like a ripped page
  3. Keep moving the mouse to select the other three sides, but this time, move the mouse outside the picture window so that the whole area is correctly selected
  4. Selections > Invert
  5. Make sure you select the right background color, and hit the Del key to remove this section
  6. Image > Effects > Drop shadow 

Converting video files from FLV to AVI

Avidemux

Privoxy

To apply one set of filters to the root page of a site, and apply a different set of filters to other pages on the same site:

#Apply this only for /index.php
{+filter{acme-main}}
www.acme.com/index.php
 
#Apply to all other pages
{+filter{acme-other}}
www.acme.com/
{-filter{acme-other} }
www.acme.com/index.php

Minimal

All you need is config.txt, and user.action+user.filter

config.txt
confdir .
logdir .
actionsfile user.action
filterfile user.filter
logfile privoxy.log
debug      1
listen-address  127.0.0.1:8118
toggle  1
enable-remote-toggle  0
enable-remote-http-toggle  0
enable-edit-actions 0
enforce-blocks 0
buffer-limit 4096
accept-intercepted-requests 0
split-large-forms 0
keep-alive-timeout 5
socket-timeout 300
handle-as-empty-doc-returns-ok 1

Ignore sites

To tell Privoxy to ignore some sites, add this to user.action:

{-filter{ignore}}
www.acme.com

Canon CanoScan LiDE 20 stops working on XP

Run test in Control Panel > Scanners and Cameras

From Canon's site, download and run its DELDRV.EXE utility

From Canon, download and run latest and greatest driver for this scanner

If still doesn't work, check that PATH variable includes path:

Control Panel > System > Advanced > Environement Variables > System Variables: Add eg. C:\WINDOWS\TWAIN_32\CNQL50

[Linux] Checking changes before/after installing application

If you only need to find files that were added/modified later than a reference point:

# Create a reference point
touch /reference
 
# Make change to filesystem
touch /tmp/dummy.txt
 
# Find all files added/modified/ after creating "/reference", ignoring /sys, and /proc:
 
find / -wholename '/dev' -prune -o -wholename '/proc' -prune -o -wholename '/sys' -prune -o -newer /reference

By definition, the "find" commands won't include files that were deleted:

# cd /
# ls -alR /tmp > b4.txt
# touch /tmp/dummy.txt
# ls -alR /tmp > after.txt
# diff -u b4.txt after.txt

[Linux] Installing and using lm_sensors

  1. apt-get install sysv-rc-conf
  2. apt-get install lm-sensors
  3. sensors-detect
  4. cat /etc/modules
  5. modprobe, and check that the module(s) is/are loaded
  6. sysv-rc-conf, and check that lm_sensors will be started at boot time

[OpenOffice 3.2.1/Calc] Copy/pasting a column with no overwrite

Right-click > Paste Special

[OpenOffice 3.2.1/Calc] Copy/paste comment to multiple cells

Copy cell, right-click to target cell > Paste Special: Selection = Notes only, Operations = Add

[OpenOffice 3.2.1/Calc] Paste clipboard without overwrite

In case you'd like to paste the contents of the clipboard at a given row and expect the existing rows to move down, here's how to do it:

  1. Copy contents to clipboard
  2. Edit > Paste
  3. Edit > Undo (reverses overwrite but highlights correct number of rows)
  4. Insert > Rows (inserts blank rows)
  5. Edit > Paste (puts data in newly inserted rows)

[LibreOffice 3.4.4] Keyboard shortcut to add/remove rows

Tools > Customize > Keyboard. First select the desired shortcut key. In the Insert category, select "Insert rows" and then click on "Modify".

To remove rows, use the Edit category, "Delete rows" command. The keyboard shortcut is CTRL+-, followed by "Delete Entire Row(s)" (LibreOffice remembers what the last action was, so you'll have to hit Enter the next time).

[LibreOffice] Print labels

Here's how to print the same label onto a label sheet:

  1. Start LO and choose New>Labels
  2. Click on the Format tab, and enter the relevant infos (If A4, Page Width=21,00cm and Height=29,70cm; I set Horizontal Pitch=Width and Vertical Pitch=Height)
  3. Save as eg. "Avery A4" and "user1"

[WinSCP] Syncing with an FTP server

Here's a script to sync a remote FTP server with a local directory, before syncing the local directory with a second, remote FTP server:

#C:\winscp.sync.ftp.script
option batch on
option confirm off
 
open ftp://me:pass@ftp.site1.com
option transfer binary
cd downloads
#Notice the ".", as we cd'ed into the remote source directory
synchronize local c:\winscp .
close
 
open ftp://me:pass@ftp.site2.com
option transfer binary
synchronize remote c:\winscp /downloads
close
 
exit

Next, download and unzip the portable version of WinSCP (to avoid the adware in the installer)

Check that the script works OK by running it manually:

winscp.exe /console /script=C:\winscp.sync.ftp.script

Finally, if you want to run this script regularly, add this command to Windows' Scheduled Tasks in Config Panel (notice the double-quotes don't include the parameters):

"C:\Downloads\WinSCP 4.2.9\WinSCP.exe" /script=C:\winscp.sync.ftp.script /log=c:\winscp.log

Note that neither WinSCP nor Windows Scheduled Tasks seems to support rotating log files, so you'll have to delete it every once in a while to prevent it from growing too big.

[SecureCRT]

To launch SecureCRT and have it open multiple tabs to a Linux host, create a shortcut on the Desktop:

"C:\Program Files\VanDyke Software\SecureCRT\SecureCRT.exe" /SCRIPT "C:\myscript.vbs"

And create the VBScript script:

# $language = "VBScript"
# $interface = "1.0"
 
Sub Main
        Set hash = CreateObject ("Scripting.Dictionary")
 
        hash.add "MyDir", "cd /usr/src/mydir"
        hash.add "Linux", "cd /usr/src/linux"
 
        keys = hash.Keys
        for index = 0 to hash.Count - 1
                Set tab = crt.session.ConnectInTab("/s 192.168.0.1")
                tab.Caption = Keys(index)
                Set tabscreen = tab.Screen
                tabscreen.Send hash.item(Keys(index)) & vbcr
        Next
End Sub

[Google Chrome]

In case you have a bunch of pages open and need to close Chrome, here's how to save the URL's so you can reload them afterwards:

  1. CTRL+SHIFT+D to create a new folder in the Boorkmarks
  2. I suggest you name the folder using the current date + time, eg. YYYY-MM-DD HH:MM
  3. Close and restart Chrome
  4. ALT+E,B to open the Bookmark Manager, right-click on the folder, and reopen the URL's

[Eudora 7]

Here's how to get Eudora to query Google instead of jump.eudora.com when searching the web:

  1. Close Eudora
  2. Lake a backup of c:\Program Files\Qualcomm\Eudora\EudoraRes.dll3.
  3. Download and run "XN Windows resource editor"
  4. Open c:\Program Files\Qualcomm\Eudora\EudoraRes.dll
  5. String Table > 124: Right-click on item 1980 > Modify String
  6. Right click and modify that string to: http://www.google.com/search
  7. File > Save
  8. Restart Eudora, and give it a try

[LibreOffice 3.5.3.2/Writer] Split view horizontally

Not available. As a work-around, click on Window > New Window to open the document in a second window and use ALT+TAB to switch back and forth.

[LibreOffice 3.5.3.2/Writer] F3 keyboard shortcut to keep searching

Not available. As a work-around, use Tools > Customize to reassign Repeat Search to F3. CTRL+F displays the search textbox, but you'll have to reach for the mouse to put the focus back on the document before using F3 or it won't work.

[LibreOffice 3.5.3.2/Writer] Underline H2 until right border

  1. Hit F11 to open the Styles and Formatting window
  2. Right click "Heading 2" and select Modify
  3. Click the Borders tab, and create a bottom border by clicking below the gray square in the User-defined window, select the thickness (width) for the line and the color you want to use. If you have a preference as to the type of line used, select that also. Click OK.

[Iron browser] Transfering passwords from Chrome

After installing SRWare Iron, the open-source version of Google Chrome, here's how to import Chrome's passwords:

  1. In Windows 7, go to C:\Users\[yourusername]\AppData\Local\Google\Chrome\User Data\Default
  2. Copy the file "Login Data" to the following folder:

    C:\Users\[yourusername]\AppData\Local\Chromium\User Data\Default

[Note Everything]

This is an Android application to write notes. To export a note, unmount and disconnect the device from the PC, export the note, replug the USB cable.

[Notepad++] Synchronize vertical scrolling in two documents

Right-click on document tab > Clone to Other View

[NotePad++] Rename "new X" tabs

Not possible. Alternatively, "use a clipboard manager (CLCL) and perform such editing in its own viewer".

[ConEmu] Use a better looking font

Use "[Raster Fonts 8x12]"

[ConEmu] Minimize to icon bar

Main > Task Bar> TSA : Check "Auto minimize to TSA"

[TCC/LE] Go back and fortch between directories

la Bash "cd -": The full command is "CDD -", but you can just type "-".

[Outlook] Recover "Deleted Items"

  1. Search for the item
  2. Drag and drop it to the right section (eg. Tasks), in the Navigation Pane

[SyncBackSE]

Here's how to add an item to a Group profile:

  1. Profiles > New to create a new profile
  2. Right-click on the Group profile > Modify
  3. Move new profile to the other side

To hide profiles that have also been added to a Group profile: Preferences > Only show groups and profiles not in a group.

[Eudora]

Here's how to edit one of Eudora's DLLs so that you can right-click on a word and launch a Google search instead of using the now defunct jump.eudora.com:

  1. Close Eudora
  2. To be safe, make a backup of c:\Program Files\Qualcomm\Eudora\EudoraRes.dll
  3. Google for "XN Windows resource editor"
  4. Open c:\Program Files\Qualcomm\Eudora\EudoraRes.dll
  5. String Table > 124: Right-click on item 1980 > Modify String
  6. Right click and modify that string to: http://www.google.com/search
  7. File > Save
  8. Restart Eudora, and give it a try